Want To Duplicate Product Variations With Its Price, Image, SKU and etc? Download This Free Plugin

Can’t Select Swatches when Product is embedded

Devon Lovings

Can’t Select Swatches when Product is embedded

Here’s an example of the error: http://testing.teamwashlife.com/product/custom-door-hanger-design/

I am using ThemeComplete’s Extra Product Options plugin to allow customers to add another product to their order but the swatches can’t be selected when they are used this way. They work great on the shop page.

Tanvirul Haque

Hi Devon,

Thanks for reaching us. We are sorry for your inconvenience.

Could you send us the latest version of the Extra product Option plugin that you are using on your site. We’ll try to investigate your issue by installing your theme on our local setup.

You can upload the plugin file in Dropbox or Google Drive and send the download link here directly.

Also could you please give me a video instruction on how you set the plugin’s option with the product? You can use this tool to reproduce the video? https://www.useloom.com It helps me to quickly figure out the issue and squash it immediately.

Looking forward to hearing from you soon.

Thank you

Tanvirul Haque

Hello Devon Lovings,

We are sorry for your inconvenience. I am transferring your issue to our development team and they will investigate your issue with our local setup.

We will bring you up to date as soon as we figure out this issue.

Thanks

Devon Lovings

I did have it working for a while but after the plugin updated it stopped working :/

Tanvirul Haque

Hi Devon,

We are sorry for your inconvenience. It’s a development local site, please login here and setup your theme. And try to reproduce your issue here.

https://wptestbox.com/devon/wp-login.php

Username: admin

Password: Fh%^Soq(H9X6ssby1B

Thank You

Devon Lovings

I was able to make it work on your test site. I unloaded all plugins except for what I needed to make it work on my site and still it didn’t seem to work.

Something weird did happen though. When I have my cache plugin activated and I clear the cache for that page and reload the page, it works on the first load but after reloading the page again, it stops working again.

I have a feeling it’s a cache issue however I disabled my cache plugin and it still is causing issues.

I wish I could figure this out.

Tanvirul Haque

Hello Devon Lovings,

It might be caching issue. I have checked it’s now working on your site, see the reproduced video here https://www.loom.com/share/e3851fc24f9f4caca8390dddce8bdc2c Kindly try to disable your all caching system, If you have Cloudflare or serverside caching enabled, try to clear the cache as well.

Thanks