Problem with WooCommerce Bundles

Jude Ward

Hi There,

The most recent version of your plugin is causing issues with WooCommerce Bundled Products on my website.

I can see from the support threads that other people have reported issues linked to the WooCommerce Bundled Products. Please can you let me know if you have isolated the issue and have a fix?

On my website, the issue occurs on Bundled products. When a customer tries to add their selection to the basket, and error appears to notify them…

“item cannot be added to cart, waist size is a required field”

This error appears even though the variations are selected for each item within the bundle. See attached screenshot…

Screenshot 2020-11-05 at 16.52.33.png

Tanvirul Haque

Hi Jude,

Thanks for reaching us. We are sorry for your inconvenience.

Could you send us the latest version of the Bundle plugin that you are using on your site? We’ll try to investigate your issue by installing that plugin on our local setup.

You can upload the plugin file in Dropbox or Google Drive and send the download link here directly.

Looking forward to hearing from you soon.

Thank you

Tanvirul Haque

Hello Jude Ward,

Could you please check my reproduced video here, actually I have not found such an issue on my local setup.

Thanks

Jude Ward

Hi There,

Sorry for the delay here, we’ve had a busy period. I’m now available to look at this issue again…

I have set up a staging Environment here: https://suziwongsta.wpengine.com/

On this environment I have done the following:

Disabled all plugins except WooCommerce, WooCommerce Product Bundles, Variation Swatches For WooCommerce and Variation Swatches For WooCommerce Pro
Activated the default Twenty Twenty theme
Cleared all Caches

After completing all of the above steps, the problem persists. To replicate the issue please visit the following pages:

https://suziwongsta.wpengine.com/product/challenge-training-suit/
https://suziwongsta.wpengine.com/product/combat-black-running-bundle/
https://suziwongsta.wpengine.com/product/black-red-jogging-kit-bundle/

On any of these pages, if you select a Variation for each product in the Bundle, then try and add the item to your basket you will get an error such as…

“Black & Red Jogging Kit Bundle” cannot be added to your cart. “Waist Size” is a required “Cotton Skinny Jogger – Black” field.

To troubleshoot the issue further, I disabled your plugin to see if the problem persists. When the “Variation Swatches” Plugin is deactivated, the problem does not happen any longer.

This obviously means that there must be an issue somewhere with your plugin when using it in conjunction with the WooCommerce Product Bundles Plugin.

I would appreciate it if someone could take a deeper look into the problem as this obviously makes the plugin completely inappropriate for use on this website until the error is resolved.

Thank you

 

Tanvirul Haque

Hello Jude Ward,

Could you please share the login credential of your staging site? Also, share the bundle plugin.

Thanks

Jude Ward

Hi the latest version of the bundles plugin is here again: https://www.dropbox.com/sh/rmp2u1nd97uete9/AAC6BvfryWmVA3_ywvYoxqSIa?dl=0

I have added you as a user to the staging environment with the following credentials:

User: getwooplugins

Pass: I&fV$5rMzD!sSezLx(eGemTs

Let me know if you need anything else.

Jude Ward

Hi There, Please can I have an update on this issue?