We’re locked at home because of covid-19, but working to support business.
We are apologize if you face any delay to get support response.
Stay safe and take care of your family and yourself.

Some Variation Swatches load as red X but update after making a selection

Nick Bork

On a new site (running Woocommerce 4), the variation swatches are not behaving correctly. On a test product that is configured, some swatches load as disabled but automatically toggle them-self as “available” once a selection is made.

Test product: https://www.ohanaapparel.com/shop/test-product/

I’ve made a video to view the behavior: https://www.loom.com/share/6e0b0dba39b44cbab69d010e0fe303ed

 

Upon page load, you’ll see the X’s

page-load.jpg

 

Choose any color or size and the options enable them-self:

selection.jpg

 

Sizes 2XL, 3XL and 4XL have explicit variations setup to charge for a different price while S, M, L and XL are all handled and caught by the default variation.

 

This behaves this way regardless of theme (I tried Storefront and TwentyTwenty in addition to Flatsome)

 

I have tried disabling ALL plugins except Woocommerce and the Swatch plugin, but the same behavior exists.

 

I recently updated to the latest version of the swatches plugin as well as to Woo 4.0 and believe that this is an issue with the “new’ release.

Nick Bork

 

I don’t know what changed in either your plugin in the recent versions but there has to have been a breaking change as the swatches did behave correctly prior to updating the plugin and applying the Woo 4 update.

I have watched the video, you deleted the “catch all”swatch for size that covers Small, Medium, Large and XL.

Unfortunately, that is not a solution. Out of the box, Woocommerce has ALWAYS allowed the ability to create the “any” variation combo and the item be in stock and available.

If I were to re-add the “Any” variation combo and disable your plugin, Woocommerce would show that those sizes are in fact available and in stock in its dropdown menus.

This particular bug did not present itself until I updated your plugin to a newer version and updated to Woo 4.

I can’t purchase and use this plugin if it doesn’t support the same basic features for variations that are the core Woo, that being the use of the “any” variation combo.

Like I said, if we disable your plugin and load the page, those options will be in stock and available using the standard drop downs.

 

Likewise, I’ve made this video to show that the “any” option does work in woo. You’ll notice that the pricing of the product is $20 (the ANY catch all) when it is the top variation for ALL sizes and when I re-order the variation combo to be last, the prices go back to the correct for 2XL, 3XL and 4XL:

https://www.loom.com/share/28c4523e5eb047c483c3141c0d8f657a

At the core, things appear to be working fine however your plugin is marking valid variation combos as out of stock when they are not. Even more weird is that when you do make a selection, those items that were disabled are then enabled.

 

 

Shamser Suzon

Hello Nick Bork,

Please, update your plugins to the latest version. Free – 1.0.78 & Pro – 1.0.47

The issue should be fixed.

Let me know how it goes. Thanks

 

Nick Bork

I only have the Free version and did updated to 1.0.78 but the issue is still present.

I don’t have a license for Pro (yet) so I have not downloaded that.

Nick Bork

Just  checking in on an update for the issue.

Nick Bork

I’ve purchased the PRO version, downloaded and activated it. Version 1.0.47.

The issue is still present

Ahmed Ehsaan

Hi Nick Bork,

Thank you for reaching out to us. Please kindly do a plugin compatibility check by doing these steps to identify the error :

=> Deactivate all of your additional plugins except WooCommerce and WooCommerce Variation Swatches Plugin.

=> See if the problem persists. If the problem resolved, you can tell which plugin might be the culprit of this error by activating your additional plugins one by one.

Looking forward to hearing from you soon.

Thank you

Nick Bork

On the original ticket submission, I already stated that I disabled all other plugins except WooCommerce and your Swatches plugins . I also stated that I tried with other themes as well.

 

I confirmed that, again, today by disabling all other plugins except WooCommerce 4.0.1 and Variation Swatches 1.0.78 + Pro 1.0.47.

 

The problem still persists.

Ahmed Ehsaan

HI Nick,

Check here: https://www.loom.com/share/171f5b7f28fa4123b3b51e19e7fd0173

Thank You

Nick Bork

Ahmed,

Your solution is to explicitly create a variation for every size option. To me, that is not a solution to a bug.

I updated the plugin again to v1.0.79. This version does resolve the issue, so what ever was in 1.0.76 that you rolled back to fixes the issue.

 

Thanks

 

Nick

Ahmed Ehsaan

1.0.79version fixed your issue? Can I close this ticket?

Nick Bork

Release notes for 1.0.79 say “Fix: Rollback some features to 1.0.76 to fix a known issue.”.

 

As long as the features that were implemented in 1.0.77+ don’t appear in 10.0.80+ and “break” the plugin again, I’m fine with closing the ticket.

I did purchase a paid PRO license, out of respect for your efforts, even though I won’t use any pro features. I wanted to support your plugin for supporting me!