Extra (random) image is loaded in the gallery

Hello,

all the product galleries show an extra “random” image (from another product) as first image.
I ve not been able to find a pattern of the bug, for example:

http://staging.schostalroma1870.com/product/gingham-navy-boxer/

show 3 pictures:

show 3 images.png

but there are only two images uploaded (and the third is clarly out of context)

but they are 2.png

 

This happens almost always on all product.

Tested with Firfox/ chrome on mac / win 10

i am gonna disable the plugin coz this way the shop is not OK.

 

 

 

Shamser Suzon

Hi Manolo Macchetta,

Thank you for reaching out to us. Please kindly do a plugin compatibility check by doing these steps to identify the error :

=> Deactivate all of your additional plugins except WooCommerce and WooCommerce Variation Swatches Plugin.

=> See if the problem persists. If the problem resolved, you can tell which plugin might be the culprit of this error by activating your additional plugins one by one.

Looking forward to hearing from you soon.

Thank you

Hello

I deactivated them all but 4:

Variation Swatches for WooCommerce
Variation Swatches for WooCommerce – Pro
WooCommerce
Select WPBakery Page Builder

Problem is still there.

 

Shamser Suzon

Hi Manolo,

Thanks for reaching us. We are sorry for your inconvenience.

Could you send us the latest version of the theme that you are using on your site. We’ll try to investigate your issue installing your theme on our local setup.

You can upload the theme file in Dropbox or Google drive and send the download link here directly.

Looking forward to hearing from you soon.

Thank you

you can download the full theme folder here (we are using a child theme)

 

staging.schostalroma1870.com/wp-content/themes.zip

Ahmed Ehsaan

Could you check now?

Nice! can you tell me what you do, coz Now i ve to do it in the “production” website ( schostalroma1870.com )

Actually,

it s not fixed 😐

when you change the option in the. Single Variation Image Preview section

there is this ugly bar on title and the button with size – But there is no “extra images”

 

The Breaker is the Catalog Mode > Show single attribute:

when checked: nice looking catalog, but extra, random image in the single product
NOT check: no extra images on single product, but ugly stuff on the catalog

 

 

Ahmed Ehsaan

Enable it to your product, I’ll remove the ugly stuff on the catalog from CSS.

Yes, but please share the CSS after,

I need to put it on the “production” website.

Ahmed Ehsaan

Here you go: https://www.loom.com/share/b1a48c4e22f3443b86bd574716953445

Thank You

All the ugly stuff is still there (the css just removed ONE set of button and the “ugly line” is still there – see the image), but no problem, I decided to pay a coder a fix it.

we already lost the Xmas window, if he cannot i ll simply NOT use your plugin.

 

 

Shamser Suzon

Hello Manolo Macchetta,

I am really sorry for the inconvenience. Your issue is SOLVED now!

Please, check and confirm me.

Thanks