Images are not changing on variation selection

Hi,

I really like your plugin and I want to buy the pro version, because it has all the features I need !

The problem is that the image variation is not working on single product. If i select a variation on the single product, the image is not changing. It’s working well on the catalog but not on the single product.

I think it’s because of my theme, so I don’t find any solution

I will be happy if you can help me find a solution

Thanks

Shamser Suzon

Hi Yohann,

Changing image is not feature of our plugin, is the feature of WooCommerce itself.

Could you disable our swatches plugin and check is it working without our plugin or not?

Thank you

Hi,

Yes without your plugin it’s working…

I think that this is something on your plugin which is malfunctionnig with my theme

Hi,

No it’s only working if you are on the first picture, but if you choose the second picture and after a variation, it’s not working… Please check

Many thanks

Shamser Suzon

Hi Yohann Cremonese,

Could you record me reproducing your issue using tool like this? https://www.useloom.com
It helps me to quickly figure out issue and squash it with immediately.

Thank you

Hi,

I can’t use Loom on my Mac (because the navigator is not safe for my Google account, si I can’t Login)

In fact the test is really simple, you select the second image on the left for example, and after you choose a variation, the image is not changing, nothing happen …

Many thanks

 

Shamser Suzon

Hello Yohann Cremonese,

In one of your previous messages, you have said that, it is working without our plugin. But I can see it is not working even without our plugin! Check this out: https://www.loom.com/share/93b669e727ca4666a00f0ee9f0d22350

Please, contact with your theme support team or WooCommerc. You are having a conflict with your theme and WooCommerce I believe.

Can I please, close the ticket now?

Thanks

Hi,

I found a solution with the developer of my theme

So it’s working now but i have a problem on mobile with the plugin

I gave you a video to explain you the situation on my website :https://www.filauraa-couture.com/produit/bavoir-ambiance-coloree/

Link of the video : https://streamable.com/5x1rc

In fact I have to double click to activate a variation, it’s really not nice for a mobile user, this problem happen only if I have image tooltip (but I really need this). If there is no tooltip it’s working normally

Thanks for your feedback and for your help

Shamser Suzon

Hi Yohann Cremonese,

Thank you for reaching out to us. Please kindly do a plugin compatibility check by doing these steps to identify the error :

=> Deactivate all of your additional plugins except WooCommerce and WooCommerce Variation Swatches Plugin.

=> See if the problem persists. If the problem resolved, you can tell which plugin might be the culprit of this error by activating your additional plugins one by one.

Looking forward to hearing from you soon.

Thank you

Hi,

I disabled all my plugins but it didn’t change anything…

I have the same error, but as I said to you only if I have an image tooltip. In the others situations it’s working. The problem is that I really need the image tooltop…

Thanks for your help

Shamser Suzon

Hello Yohann Cremonese,

We have tested in our local test platform with the tooltip. It’s working fine in mobile!

Are you using iOS or Android?

Thanks

No it’s okay for my website sorry

For my mobile I don’t have the blue square anymore, but i always have to click twice the variations to activate it. On the first click it’s activating the image tooltip and a second one activate the varaiation. It’s not so nice for the user….

Hi

I made some tests on different devices, i have this bug only on IOS Device, no problem on Android

Many thanks

I discover a new thing,

I only have the problem if I assign a default variation to be chosen

If I don’t select a default variation, I don’t have the problem

Ahmed Ehsaan

Hi Yohann Cremonese,

Could you record me reproducing your issue using tool like this? https://www.useloom.com
It helps me to quickly figure out issue and squash it with immediately.

Thank you

Hi,

Did you find something ??

I still have The problem…

Many thanks

Shamser Suzon

Hello Yohann Cremonese,

You had a conversation with our team leader yesterday via the live chat. As per that, we have found the issue and will fix it in the next update of the plugin by this week hopefully.

So, can I please, close the ticket for now? If the next update don’t fix your issue then please, feel free to report via a new ticket. You can give your present ticket’s referrence.

Please, let me know.

Thanks

Okay,

Just if you can keep me inform when you publish the update

Many thanks