Plugin interferes with load more on WooCommerce

  1. Currently it appears that the swatches plugin is preventing our WooCommerce store from loading more products on the page. If you try to scroll to where it is supposed to automatically load more items it freezes and can’t load them. Could you take a look at this?

Ahmed Ehsaan

Hi Erik,

Download this file: https://www.dropbox.com/s/fo6tv3kfkrbtkg4/woocommerce.zip?dl=0 and unzip it inside your child theme.

Check this guideline: https://www.useloom.com/share/22b098d2febe40f6889a07e1dbb458db

Thank You

Ahmed Ehsaan

Hi Erik,

Thanks for reaching us. We are sorry for your inconvenience.

Could you send us the latest version of the theme that you are using on your site. We’ll try to investigate your issue installing your theme on our local setup.

You can upload the theme file in Dropbox or Google drive and send the download link here directly.

Looking forward to hearing from you soon.

Thank you

Hey there.

Sorry somehow missed the response and didn’t see any notification in my email. That almost fixed it. It is now loading more but the formatting is off- goes all in one column instead of the three columns (see image)

Ahmed Ehsaan

Hi Erik,
If you are using Shopkeeper theme. please upload your child theme and follow the guideline

explained here

Download this file: https://www.dropbox.com/s/fo6tv3kfkrbtkg4/woocommerce.zip?dl=0 and unzip it inside your child theme.

Check this guideline: https://www.useloom.com/share/22b098d2febe40f6889a07e1dbb458db

Thank You

Thank You

Ahmed Ehsaan

Check now.

Ahmed Ehsaan

Hi Erik,

Thanks for reaching us. We are sorry for your inconvenience.

Could you send us the latest version of the theme that you are using on your site. We’ll try to investigate your issue installing your theme on our local setup.

You can upload the theme file in Dropbox or Google drive and send the download link here directly.

Looking forward to hearing from you soon

Thank you

Here is link to theme: https://www.dropbox.com/s/c8vwdm2m48ym5np/themeforest-WewjbACD-shopkeeper-ecommerce-wp-theme-for-woocommerce.zip?dl=0

 

Ahmed Ehsaan

Hi Erik Quick-Warner,

Thank you for reaching out to us. Please kindly do a plugin compatibility check by doing these steps to identify the error :

=> Deactivate all of your additional plugins except WooCommerce and WooCommerce Variation Swatches Plugin.

=> See if the problem persists. If the problem resolved, you can tell which plugin might be the culprit of this error by activating your additional plugins one by one.

Looking forward to hearing from you soon.

Thank you

I just did a test. Deactivated plugins then activated the swatch plugin. It’s the one that causes the issue.

https://www.dropbox.com/s/b3jsw4uk1anbg4n/Screen%20Recording%202019-11-25%20at%208.13.08%20AM.mov?dl=0

You can view the screencast above that shows it’s this plugin causing the issue.

Again for our convenience: here’s our theme file: https://www.dropbox.com/s/c8vwdm2m48ym5np/themeforest-WewjbACD-shopkeeper-ecommerce-wp-theme-for-woocommerce.zip?dl=0

Thanks,

Ahmed Ehsaan

Let me help you step by step.

Install Chid theme.
Inside child theme create WooCommerce Folder. Inside WooCommerce folder create blank content-product.php

And then let me know.

Done- What’s the next step? Please provide all steps if you can. Once I have a blank file nothin loads (as expected)

Ahmed Ehsaan

Could you rename this file: COPY_content-product_COPY.php from content-product.php

And then let me know.

Still does not work. I’ve tried removing the file from the theme that also did not work. I also created a blank file like you mentioned and it did not work. When I put a blank content-product.php then no products show up. Please advise. (PS I changed the blank file to now have the name _copy so that the store can still function until you are ready to test more things)

Ahmed Ehsaan

I am sorry for the late response. I’ve been on the leave.

Could you provide me your FTP access. If we can’t fix it, we’ll refund.

Thank You

Hi Ahmed,

No problem. Thanks for getting back. FTP info added to ticket. I feel like it’s close b/c the items do load, just incorrectly (the dropbox video above shows how they are loading as a reminder). Appreciate your help!

 

Ahmed Ehsaan

I can’t login: https://www.loom.com/share/d7cd6a76f72f4b28ab0abb86ece84861

Thank You

I updated with new password. I think the issues was you used “HTTP” in the server which shouldn’t be there. I didn’t add that in the ticket but I’m guessing it must auto add it.

Use sftp and port 2222

 

It actually appears to be working now. Maybe you were able to provide a fix in an update or the theme maker did?

Shamser Suzon

Hello Erik Quick-Warner,

Nice to hear that your issue is resolved now. Can I please, close the ticket now?

Thanks