Fatal error when installing both basic and pro plugin

Stan Tan

Hi,

When I install both the free and premium plugin, I get a fatal error.

Fatal error: Class ‘WVS_Settings_API’ not found in /home/bobtheminer/portal.bobtheminer.com/wp-content/plugins/woo-variation-swatches/woo-variation-swatches.php on line 393

 

Stan

Ashiquzzaman Kiron

Hi Stan Tan,

Thank you for reaching out to us. Please kindly do a plugin compatibility check by doing these steps to identify the error :

=> Deactivate all of your additional plugins except WooCommerce and WooCommerce Variation Swatches Plugin.

=> See if the problem persists. If the problem resolved, you can tell which plugin might be the culprit of this error by activating your additional plugins one by one.

Looking forward to hearing from you soon.

Thank you

Stan Tan

Hi,

I deactivated all plugins then installed Swatch Pro and still received the fatal error.

Can you suggest another solution?

 

Stan

Ashiquzzaman Kiron

Hi Stan,

Thanks for reaching us. We are sorry for your inconvenience.

Could you send us the latest version of the theme that you are using on your site. We’ll try to investigate your issue installing your theme on our local setup.

You can upload the theme file in Dropbox or Google drive and send the download link here directly.

Looking forward to hearing from you soon.

Thank you

Ashiquzzaman Kiron

Hi Stan,

I tried Storefront theme with latest version in my local setup. Didn’t face any problem – https://www.useloom.com/share/919bb2de01c44fb590a544b6b2f0bce4

Could you record me reproducing your issue using tool like this? https://www.useloom.com
It helps me to quickly figure out issue and squash it with immediately.

And also can you please give us a temporary admin access to your site? We’ll try to investigate the issue for you.

You can add new users by going to Users > Add New set the user and password for us, set the role to admin and set the info here.

And add your site URL, login username, and password in the site login area. Follow this guideline: https://www.useloom.com/share/27c1f2ac633c4060b2da883d946107d7

Hope to hear from you soon!

Thank you

Ahmed Ehsaan

Hello stanley.tan,

Please check here: https://www.useloom.com/share/6f8959dbeba241b49d6a4b810a840d4c

Your site is running on pretty older version of php, check here: https://www.useloom.com/share/6f8959dbeba241b49d6a4b810a840d4c

Please upgrade it php 5.6 and higher. Here is our commerce system requirement: https://docs.woocommerce.com/document/server-requirements/

Thank you very much.

Ashiquzzaman Kiron

Hi Stan,

Just checking in, Did you manage to resolve the issue ?

Regards,
Ashiq